Motorhome Forums, Motorhome Discussion, Motorhome Chat - Reply to Topic

Thread: Elctrolux/Dometic Traveller generator - Help needed please Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Motorhome Forums, Motorhome Discussion, Motorhome Chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
01-11-2017 21:36
Paintslee Hi all. I hope someone here might be able to help with my Traveller genny. It's a 2.5 kw LPG genny slung underneath my 1996 Iveco motorhome. After the recent hurricane in Ireland I was using it to power mine and three neighbours houses and had it resting on the ground. Big mistake on my part. It overheated and buckled the fan on the motor resulting in the crank shaft shearing. Replacing the crank shaft isn't a problem but getting a new rotor with fan and ring gear is. The genny is probably 20 years old but only has 65 hours on the clock and worked well until now. I've just sent an email to Derwent Electrical Service from a link posted above but I'm not optimistic. If anyone knows someone who has one scrapped or one to sell Id be very interested.
15-08-2013 12:06
JustRadio Garage advise butterfly valve now freed, engine running, but no electricity.....

Motor ran in failed flat out mode for maybe a minute on two separate occasions, (like 30 seconds each time), well you have to check them twice, it MIGHT have put itself right.

I await the fate of my garage bill but as always advice I can prompt them with, (so I don't sound like the dork I am), always appreciated.

John
13-08-2013 21:53
Littlebt
Protection is the cure

The next time you park up for sometime ie: the winter, make sure you drain the carb completely then no residue will occur. Simples !!
13-08-2013 20:48
JockandRita
Quote:
Originally Posted by JustRadio
Hi and thanks very much for all the info here. My Traveller has decided to rev flat out, local garage man says the carb is jammed and he doesn't know where to get another. I will pass on your "expert" link and hope this will help. Am hoping the revving flat out won't have bust something else.....

Any other info on spares etc that may have come to light since the post would be most gratefully received!

Thanks
John
Any Honda genny spares outlet. I am advised that the engine is a GX160

My butterfly valve was gummed up until I recently used carb cleaner on both my Traveller genny carburetor, and that of a fellow MH owner. Both our gennies start first time now.

HTH,

Jock.
13-08-2013 19:01
JustRadio Hi and thanks very much for all the info here. My Traveller has decided to rev flat out, local garage man says the carb is jammed and he doesn't know where to get another. I will pass on your "expert" link and hope this will help. Am hoping the revving flat out won't have bust something else.....

Any other info on spares etc that may have come to light since the post would be most gratefully received!

Thanks
John
26-05-2011 17:48
HMFIC Hi Jock, recieved thePM and will try to take a look next time I am home. Hopefully this will resolve the problem

Thank you very much for the PM

Regards

Paul
26-05-2011 12:25
JockandRita
Quote:
Originally Posted by Mrplodd
Hi Jock

Sorry to hear you are having problems, I sympathise as I am sure you will recall we did converse at length about these pesky genny's a while ago.

Have you thought about fitting a manual choke cable?? operable from inside, just like cars used to have all those years ago!! Cheaper than a new solenoid!

Remember KISS

Keep It Simple Stupid
Thanks Andy. Yes I do remember conversing, but now it's Paul above who is still having the problems.

With all that I have done, ours is running as sweet as a nut, and starting first time too.........................for now (fingers crossed).

I have PM'd Paul, detailing the steps I took, after stripping down and cleaning the carburettor and jet, as I too was beginning to suspect the solenoid, as per Derwent's suggestion to me also.

Cheers for now,

Jock.
26-05-2011 12:08
Mrplodd Hi Jock

Sorry to hear you are having problems, I sympathise as I am sure you will recall we did converse at length about these pesky genny's a while ago.

Have you thought about fitting a manual choke cable?? operable from inside, just like cars used to have all those years ago!! Cheaper than a new solenoid!

Remember KISS

Keep It Simple Stupid
26-05-2011 11:53
JockandRita
Quote:
Originally Posted by HMFIC
After speaking with the expert on the matter (and thanks Jock for the link) he also gave me a few good tips on what to look for.
No problems Paul.

PM on it's way.

Cheers,

Jock.
26-05-2011 06:56
HMFIC Hi All. It's been a while but been busy and had to start work.......anyway the end result with the generator is that the solenoid is on it's way out.

I have stripped the carb, changed the fuel and still the dam thing will not start from cold from inside the van.

After speaking with the expert on the matter (and thanks Jock for the link) he also gave me a few good tips on what to look for.

So there we are. I can replace the switch at a cost of around one hundred nicker or for the very few times I use the generator just get out of the van and start it from cold from out side................

I think the later of the two is the best economical way although I am one for wanting things to work if they are supposed to so I might just buy a new one.


Thank for all the good info and help received on this issue.

Cheers
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome