Motorhome Forums, Motorhome Discussion, Motorhome Chat - Reply to Topic

Thread: Loss of power Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Motorhome Forums, Motorhome Discussion, Motorhome Chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
04-07-2021 22:58
Glandwr Whereabouts are you? I was plagued with a mysterious loss of power (on a Sprinter) for years a diesel specialist sorted it near Wrexham.
04-07-2021 22:46
jiwawa Hi Mark and welcome to the forum.

I'm just giving your post a bump. You certainly seem to have covered a lot of bases but hopefully someone will have a light-bulb moment.
04-07-2021 10:37
Mark Suter
Loss of power

mark suter
I have a Peugeot boxer TD 1.9 XUD motorhome
Year 2000
No ECU

I’ve got loss of power below 2000 rpm, had egr valve replaced, injectors checked , still experience a loss of power at lower speeds. Checked all turbo pipes and hoses all seem ok, replaced all pipe clips with stronger ones just in case a small leak. Turbo spools up and kicks in above 2000 rpm, mechanic says turbo looks ok Still loss of power. I’m scratching my head , 2 mechanics looked at this no issue resolved. Not smoking when running after a mile, not overheating, smokes on starting and seems to miss slightly, gets better when warmer.
Had timing belt done along with rest of belts , still loss of power, Any ideas please?

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome