Motorhome Forums, Motorhome Discussion, Motorhome Chat - Reply to Topic

Thread: Dometic B2100 air conditioning not working Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Motorhome Forums, Motorhome Discussion, Motorhome Chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
20-03-2014 23:59
fletch6 Sounds like the compressor maybe faulty. Pull the wires off it and see if it still trips the supply.
03-03-2014 11:18
finyar
Dometic B2100 air conditioning not working

Hi All,
I would really appreciate some advice on my Dometic B2100 air conditioning unit. When I turn it on, it runs for about 30 secs to a minute and then trips my garage EHU.

I have also tried to plug the van into the house mains ( seperate board) and it also trips that one.

I have read all the posts on the B2200 issues and none seem to apply.

I have checked around the external of the roof unit and the airflow or the water pipes don't seem to be blocked.

I could not remove the cover of the unit as it looks like the fasteners need to be replaced each time it is opened.

I have emailed Domectic diectly as advised by Chris( Premier) to another poster but in reality they just told me to visit an approved dealer.

Any help would be much appreciated

Raymond

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome