Adria Twin Fridge/Step problem - Motorhome Forums, Motorhome Discussion, Motorhome Chat

User Tag List

 1Likes
  • 2 Post By griffly16
 
LinkBack Thread Tools
post #1 of 6 (permalink) Old 21-12-2016, 10:54 Thread Starter
Senior Member
 
Join Date: Jul 2006
Location: Warwickshire
Posts: 393
Thanks: 0
Thanked 0 Times in 0 Posts
Adria Twin Fridge/Step problem

Hi

My 2005 Adria Twin has just had the alternator replaced as it wasn't charging the main battery. I'd noticed that the fridge wasn't working when the engine was running, and also the step didn't retract like it used to.

Now the alternator has been replaced, I was expecting/hoping that the fridge would run on 12v, and also that the step would retract automatically when starting the engine. The step works fine via the switch when the engine is off.

I've looked through some forums but can't find anything specific to the Adria - I'm assuming it's a fuse/relay problem but there are so many of them it's difficult to trace.

Anyone have any ideas?

Thanks
Griff
griffly16 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 21-12-2016, 12:45
Senior Member
 
Pudsey_Bear's Avatar
 
Join Date: Sep 2008
Location: Keighley, Still in Gods County.
My Motorhome: 2002 Bessacarr E745.
Posts: 37,124
Thanks: 1,510
Thanked 959 Times in 900 Posts
Send a message via AIM to Pudsey_Bear Send a message via Yahoo to Pudsey_Bear
Sounds like they disturbed, broke, or removed something when fitting it, I'd go back and ask them nicely to do the job properly.
Pudsey_Bear is offline  
post #3 of 6 (permalink) Old 21-12-2016, 13:19 Thread Starter
Senior Member
 
Join Date: Jul 2006
Location: Warwickshire
Posts: 393
Thanks: 0
Thanked 0 Times in 0 Posts
I did mention it to them but they said it was just the usual connector to the alternator - nothing extra. I'm suspecting that as the step/fridge didn't work before the replacement that it's something else other than the alternator.
griffly16 is offline  
 
post #4 of 6 (permalink) Old 21-12-2016, 13:46
Senior Member
 
Pudsey_Bear's Avatar
 
Join Date: Sep 2008
Location: Keighley, Still in Gods County.
My Motorhome: 2002 Bessacarr E745.
Posts: 37,124
Thanks: 1,510
Thanked 959 Times in 900 Posts
Send a message via AIM to Pudsey_Bear Send a message via Yahoo to Pudsey_Bear
Quote:
Originally Posted by griffly16 View Post
I did mention it to them but they said it was just the usual connector to the alternator - nothing extra. I'm suspecting that as the step/fridge didn't work before the replacement that it's something else other than the alternator.
That bit of information was a bit slow coming

Could be a relay you need a wiring diagram really, Adria should have on in the manual or online possibly, then you can trace any fault, in theory.
Pudsey_Bear is offline  
post #5 of 6 (permalink) Old 21-12-2016, 16:03 Thread Starter
Senior Member
 
Join Date: Jul 2006
Location: Warwickshire
Posts: 393
Thanks: 0
Thanked 0 Times in 0 Posts
Didn't make it clear enough in the original post - sorry.

I've got the wiring diagram but it's double-dutch to me. I was hoping that someone with the same van may have more information regarding the location of the possible faulty relay/fuse as they're everywhere and not labeled at all....
Pudsey_Bear and Pudsey_Bear like this.
griffly16 is offline  
post #6 of 6 (permalink) Old 21-12-2016, 17:53
Senior Member
 
Pudsey_Bear's Avatar
 
Join Date: Sep 2008
Location: Keighley, Still in Gods County.
My Motorhome: 2002 Bessacarr E745.
Posts: 37,124
Thanks: 1,510
Thanked 959 Times in 900 Posts
Send a message via AIM to Pudsey_Bear Send a message via Yahoo to Pudsey_Bear
Quote:
Originally Posted by griffly16 View Post
Didn't make it clear enough in the original post - sorry.

I've got the wiring diagram but it's double-dutch to me. I was hoping that someone with the same van may have more information regarding the location of the possible faulty relay/fuse as they're everywhere and not labeled at all....
Could you take a pic of the diagram or scan it and post it, it may help, as you say it'll be a relay, possibly just a wire come off or broken usually., at least you know the step is working and can control it, could you bypass the wiring to the 12v side of the fridge to see if it is working, you could have more than one problem.
Pudsey_Bear is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Motorhome Forums, Motorhome Discussion, Motorhome Chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome