Lunar Champ A630 wiring problems - Motorhome Forums, Motorhome Discussion, Motorhome Chat

User Tag List

 
LinkBack Thread Tools
post #1 of 7 (permalink) Old 23-01-2009, 15:16 Thread Starter
Junior Member
 
Join Date: Jan 2009
Location: Oxfordshire
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Lunar Champ A630 wiring problems

Hi, We have recently bought an 2004 A630,nice but could not get the fridge working on 12V. Fuses all ok.Does anyone know where the relay is situated? Also, while looking for the fridge problem, suddenly all rear interior lights faulty, cooker has no power, fridge has no power. Lights work over the cooker and in the overcab bed!!! Again fuses all ok and all plugs secure. Any ideas as to what else to check before it goes to a repair shop? Apart from that it was great over New Year (when the light still worked!) plenty warm enough with the blown air heat.
Thanks
Steve
SteveOxon is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 23-01-2009, 15:35
Senior Member
 
Join Date: May 2005
Location: Gloucestershire
Posts: 463
Thanks: 32
Thanked 19 Times in 13 Posts
Fridge relay

The relay on our H621 Champ is underneath the fridge beneath a removable cupbord floor, it was just hanging in the wiring until I taped it up.
Did also have problems with fuse blowing, Lunar only ouse the User outputs, I dont think they use the dedicated fuses of the Calibra unit, do also check for trapped wires under that cupboard floor

Best of luck

Mike
mike800966 is offline  
post #3 of 7 (permalink) Old 30-01-2009, 16:48 Thread Starter
Junior Member
 
Join Date: Jan 2009
Location: Oxfordshire
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Thanks for that Mike, but couldn't find the relay there on mine.

Weird thing is after a week the rear lights worked again. Fridge still didn't so took the van to a repair place nearby. Showed him what was wrong, and you can guess the rest - fridge worked fine when he switched it on!!!.

So it appears I have a (possibly serious) intermittent fault somewhere. Now we are just going to use it and hope it works ok.

Steve
SteveOxon is offline  
 
post #4 of 7 (permalink) Old 30-01-2009, 17:52
Senior Member
 
SandJ's Avatar
 
Join Date: May 2005
Posts: 5,135
Thanks: 0
Thanked 0 Times in 0 Posts
Steve,

We had a 2004 A630

Now from memory the wires go along under the bench seatsand could easily get trapped or dislodged.

Heating was excellent

Enjoy your travells and hope you get it sorted.

Steve
SandJ is offline  
post #5 of 7 (permalink) Old 08-02-2009, 22:41
Junior Member
 
Join Date: May 2005
Location: Gloucestershire
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Hi Steve,
I have an A601 and we had a slight problem with wiring. There is a multi connection block located in the wiring loom in the channel below the run of wall cupboards above hob/sink. This was slightly loose and just needed pressing together, could give an intermittent fault.
Good luck,
Rob
RobH is offline  
post #6 of 7 (permalink) Old 21-01-2019, 20:49
Junior Member
 
Join Date: Jan 2019
My Motorhome: I drive...
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Hi I have a lunar champ 601 and the lights went out above the bench seat and the toilet light are out is there a fuse located???
Steve3499 is offline  
post #7 of 7 (permalink) Old 22-01-2019, 17:10
Senior Member
 
Join Date: Jun 2007
Location: Belfast
My Motorhome: Hymer Exsis-i 504
Posts: 5,538
Thanks: 193
Thanked 291 Times in 278 Posts
Have you checked the fuses on the elektrobloc - or whatever lunar uses?

And welcome to the forum Steve.

Jean
jiwawa is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Motorhome Forums, Motorhome Discussion, Motorhome Chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome