Euroyacht electric step - Motorhome Forums, Motorhome Discussion, Motorhome Chat

User Tag List

 
LinkBack Thread Tools
post #1 of 8 (permalink) Old 20-01-2010, 17:09 Thread Starter
 
Join Date: May 2007
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Euroyacht electric step

....having a problem with the step of my Euroyacht 18, since the cold weather. The motor spins when the button is pressed (or the engine is started) but nothing seems to happen. It sounds like the shaft is spinning but something needs tightening. Can anyone help, please..?? Thanks..!
Tony
transittony is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 08-02-2010, 11:09
Junior Member
 
Join Date: Oct 2007
Location: UK
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
See if it has disengage as it has a manual setting has a lever on side of motor that you push or pull. Also check electrical connections and fuse connection.
mine did same I had just a whirring noise eveuntually didnt even get the noise changed fuse and is now great.
Zebuk is offline  
post #3 of 8 (permalink) Old 09-09-2010, 08:24
Member
 
Join Date: Sep 2010
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
Hi I am new and have just bought a Mobilvetta Euroyacht 180. Do you have a set af manuals you could copy/ scan for me as mine are not in the MH

Thanks
HMFIC is offline  
 
post #4 of 8 (permalink) Old 10-09-2010, 16:34
Junior Member
 
Join Date: Oct 2007
Location: UK
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
HI
Congratulations we are really pleased with ours.
Re manuals we have an iveco chassis and engine the manual for that is ok.
The mobilvetta manual we have is not very useful as it has very little detail in it you will be best to just explore your home and work it out if you have any Specific Questions please dont hesitate to ask and if I can answer I will.

Regards

Zeb..
Zebuk is offline  
post #5 of 8 (permalink) Old 10-09-2010, 17:17
Junior Member
 
Join Date: Oct 2009
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Euroyacht electric step

Quote:
Originally Posted by transittony
....having a problem with the step of my Euroyacht 18, since the cold weather. The motor spins when the button is pressed (or the engine is started) but nothing seems to happen. It sounds like the shaft is spinning but something needs tightening. Can anyone help, please..?? Thanks..!
Tony

I had a 190LX? with a similar problem which turned out to be a broken roll pin on the motor shaft.
hailman is offline  
post #6 of 8 (permalink) Old 10-09-2010, 20:22
Member
 
Join Date: Sep 2010
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
Zebuk, Thanks for you reply it is appreciated. If possible I would like to have a copy of the Iveco manuals. I will explore the MH and come back to you if I have any specific questions.

Not too sure how we can get the copy of the manuals over to me

Once a again thank you very much


HMFIC
HMFIC is offline  
post #7 of 8 (permalink) Old 11-09-2010, 16:54
Junior Member
 
Join Date: Oct 2007
Location: UK
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
We are in greece a the mo so would be very difficult to arrange if you search you should be able to download from iveco or the ford web site.
Zebuk is offline  
post #8 of 8 (permalink) Old 11-09-2010, 22:38
Member
 
Join Date: Sep 2010
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
OK will do, thanks for your help I will see what I can do.

Enjoy your time in greece.
HMFIC is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Motorhome Forums, Motorhome Discussion, Motorhome Chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome