swift problems - Motorhome Forums, Motorhome Discussion, Motorhome Chat

User Tag List

 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 26-03-2005, 15:35 Thread Starter
Senior Member
 
Join Date: Nov 2000
Posts: 5,753
Thanks: 0
Thanked 0 Times in 0 Posts
swift problems

hi i have a swift sundance 630l on which the electric step works like me when it feels like it,cant fault the dealer though he is ok
Anonymous is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 26-03-2005, 16:39
 
Join Date: May 2005
Posts: 275
Thanks: 0
Thanked 0 Times in 0 Posts
Hi Nick

We've got a Hymer witha lazy electric step. Dirt gets into the mechanism and makes it slow down and make a grinding noise. Put a post on the site earlier and the main suggestion was mud flaps, not got round to it yet so hubby cleans it with a toothbrush (no toothpaste though - just soapy water). Don't know if this helps or whether yours is an electrical problem.
We all seem to have somethong to challenge us - Good luck
Jeanann is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Motorhome Forums, Motorhome Discussion, Motorhome Chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome