Macerator toilet starting to smell - Page 3 - Motorhome Forums, Motorhome Discussion, Motorhome Chat

User Tag List

Reply
 
LinkBack Thread Tools
post #21 of 22 (permalink) Old 30-06-2014, 23:30
Senior Member
 
DABurleigh's Avatar
 
Join Date: May 2005
Location: Basingstoke
Posts: 13,788
Thanks: 0
Thanked 2 Times in 2 Posts
Personal Aire
I can think of many things but none can be relevant as there is no link with the van heater, which is only when your problem occurs

Dave
DABurleigh is offline  
Sponsored Links
Advertisement
 
post #22 of 22 (permalink) Old 01-07-2014, 13:19 Thread Starter
Senior Member
 
Christine600's Avatar
 
Join Date: Jan 2011
Location: By the coast
My Motorhome: Charisma
Posts: 5,551
Thanks: 21
Thanked 28 Times in 28 Posts
Quote:
Originally Posted by DABurleigh
I can think of many things but none can be relevant as there is no link with the van heater, which is only when your problem occurs

Dave
It was not only then - but heating the van amplified the smell. The ALDE radiator tube is close to the toilet so perhaps the contents of the macerator pump got heated.

I'm glad vinegar seem to have helped.

My boat owning friend thinks these toilets need a service each year or two. Changing rubber seals etc. But mine never had one.
Christine600 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Motorhome Forums, Motorhome Discussion, Motorhome Chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome