Burstner Delphin 680 Ebox I LCD Control Interface Problem - Motorhome Forums, Motorhome Discussion, Motorhome Chat

User Tag List

 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 06-09-2019, 17:53 Thread Starter
Junior Member
 
Join Date: Jun 2019
My Motorhome: I drive...
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Burstner Delphin 680 Ebox I LCD Control Interface Problem

Hi all
I have just tried to start / monitor my Burstner 12v system via the LCD Control Panel. The LCD Panel attempts to display a text initialisation screen then immediately reverts to a 'black' (high contrast) LCD display. When inserted into either of two 'holsters' for the panel the results are the same - black display. I have used switch cleaner on the contacts at the rear of the panel and changed the battery in LCD the control panel. An audible click can be heard in the Ebox when the LCD panel is inserted into either holster suggesting it is communicating with it. And, therefore I think I have a faulty Control Panel and not main Electronics Unit. Both leisure and van (Renault Master) batteries are within fully charged range and all fuses have been checked and are OK.

Has anyone experienced similar problems? I look forward to your replies.
Many thanks in advance.
Hafod is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 06-09-2019, 19:50
Senior Member
 
raynipper's Avatar
 
Join Date: Aug 2008
Location: Normandy. Just up the D903 from the roundabout with the D15
My Motorhome: Hobby 750 now sold.
Posts: 19,945
Thanks: 1,012
Thanked 355 Times in 335 Posts
Send a message via Skype™ to raynipper
Wish I could offer some help Ha.

Ray.

The FSA licensed a twice convicted fraudster to handle our life´s savings. Guess what? He robbed us of £750,000. http://raynipper.com
Brexit is madness orchestrated by the insane.
raynipper is online now  
post #3 of 3 (permalink) Old 07-09-2019, 21:45
Senior Member
 
Join Date: Jun 2007
Location: Belfast
My Motorhome: Hymer Exsis-i 504
Posts: 6,555
Thanks: 193
Thanked 335 Times in 321 Posts
Welcome to the forum hafod.

I'm afraid I can't help but I'm giving your post a boost.

Would it be an idea to post a pic, in case the same unit is used in other MHs?

Jean
jiwawa is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Motorhome Forums, Motorhome Discussion, Motorhome Chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome