Battery warning light remaining lit - Motorhome Forums, Motorhome Discussion, Motorhome Chat

User Tag List

 
LinkBack Thread Tools
post #1 of 6 (permalink) Old 17-09-2011, 18:21 Thread Starter
Junior Member
 
Join Date: Sep 2011
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Battery warning light remaining lit

Recently bought 1991 Benimar 6000STL, which is great. However, the battery warning light on the dashboard doesnít always go out on engine start. Itís OK after a couple of false starts. Iíve had the alternator checked and replacement is recommended but I wondered whether or not it might be a faulty relay. I canít find anything that might be a relay. Iíd welcome views about this.
jim424 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 17-09-2011, 18:47
Senior Member
 
BillCreer's Avatar
 
Join Date: Jan 2010
Location: Chorlton-Cum-Hardy
My Motorhome: Hymer B584
Posts: 3,265
Thanks: 44
Thanked 77 Times in 69 Posts
Hi,

Don't you trust the people who tested the alternator?

For that problem I would have checked the alternator drive belt, the cables from the alternator and then the alternator.

Cheers
Bill
BillCreer is offline  
post #3 of 6 (permalink) Old 17-09-2011, 19:06
Senior Member
 
Join Date: May 2011
Location: sheffield
Posts: 1,143
Thanks: 0
Thanked 0 Times in 0 Posts
more likely to be the brushes making intermitent contact with the slip rings and on their last legs....
i ve changed them years ago but the slip rings are usually that worn , you get the picture !
spatz1 is offline  
 
post #4 of 6 (permalink) Old 18-09-2011, 00:03
Member
 
Join Date: Mar 2008
Posts: 79
Thanks: 0
Thanked 0 Times in 0 Posts
I had something like this a couple of weeks ago. In the end had to change to alternator. In my case the light was on constantly.
yorksbill is offline  
post #5 of 6 (permalink) Old 18-09-2011, 01:03
Senior Member
 
Join Date: May 2005
Location: North East Lincolnshire
Posts: 3,234
Thanks: 0
Thanked 0 Times in 0 Posts
Hi Jim!

Red light goes out when alternator produces sufficient current.
Red light does NOT go out - alternator NOT producing sufficient current.
Alternator NOT supplying sufficient current - FLAT BATTERY!!
UncleNorm is offline  
post #6 of 6 (permalink) Old 18-09-2011, 08:57
Senior Member
 
rayc's Avatar
 
Join Date: Jun 2008
Location: Corfe Mullen, Wimborne Dorset
My Motorhome: Pilote 740C Sensation
Posts: 7,731
Thanks: 67
Thanked 275 Times in 251 Posts
Personal Aire
It is the symptoms of a failing alternator and we have to assume the people you used diagnosed it correctly.
If you want a tester the one in the link below is good for basic testing and will not break the bank:
http://www.towsure.com/product/Batte...tor_LED_Tester
rayc is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Motorhome Forums, Motorhome Discussion, Motorhome Chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome