Sargent EC100 Control Panel - Motorhome Forums, Motorhome Discussion, Motorhome Chat

User Tag List

 
LinkBack Thread Tools
post #1 of 7 (permalink) Old 25-02-2011, 18:36 Thread Starter
Senior Member
 
StewartJ's Avatar
 
Join Date: Nov 2009
Location: SW Northumberland
My Motorhome: Hymer B588DL
Posts: 649
Thanks: 3
Thanked 13 Times in 8 Posts
Sargent EC100 Control Panel

Hi all, can anyone assist, FW tank level indicators on control panel show tank full regardless of level, emptied tank today but still showed full. Tried the usual panel reset (removal of plug at rear for 30 secs, switching off EC225 charger, then powering on EC100 while pressing leisure battery button) so if anyone knows of another reset procedure I'd be grateful.

We are away in MH at present so lack of level indication is a pain.

Stewart

The point is thatīs not the Point!
StewartJ is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 25-02-2011, 18:46
Senior Member
 
wakk44's Avatar
 
Join Date: Jun 2006
Location: Notts
My Motorhome: Hymer B644
Posts: 4,250
Thanks: 0
Thanked 0 Times in 0 Posts
Try sending a pm to Ian Sargent >>>HERE<<< he is a very helpful trade member.

cheers Steve
wakk44 is offline  
post #3 of 7 (permalink) Old 25-02-2011, 21:06 Thread Starter
Senior Member
 
StewartJ's Avatar
 
Join Date: Nov 2009
Location: SW Northumberland
My Motorhome: Hymer B588DL
Posts: 649
Thanks: 3
Thanked 13 Times in 8 Posts
Quote:
Originally Posted by wakk44
Try sending a pm to Ian Sargent >>>HERE<<< he is a very helpful trade member.
Thanks for that Steve, being Friday night I'll wait and see if he's online later if not I'll try a pm

Stewart

The point is thatīs not the Point!
StewartJ is offline  
 
post #4 of 7 (permalink) Old 27-02-2011, 21:57
Senior Member
 
Join Date: Feb 2008
Posts: 356
Thanks: 0
Thanked 0 Times in 0 Posts
Hi Stewart, sorry for missing your post, I would suggest that you could start by disconnecting the water level connector on the back of the control panel, to see if this clears the problem (obviously the water level should not display)
If this has cleared the problem then you could locate the water level sensor and check the connector.
It could be that the connector has water in it, this could be due to that the connector is not located away from the road spray.
If you can dry this out then hopefully this should clear the problem.

If the problem is still present after checking and drying (if required) then if you send us a PM or email one of our technical people will call you with some other things to check.

[email protected]

Best regards

Ian Sargent
Sargent is offline  
post #5 of 7 (permalink) Old 16-03-2019, 13:31
Junior Member
 
David e's Avatar
 
Join Date: Mar 2019
My Motorhome: I drive...
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Hi everyone I am new to the forum can anyone tell me if I can update a EC100 Control Panel to the latest digital one please Dave
David e is offline  
post #6 of 7 (permalink) Old 16-03-2019, 14:11
Senior Member
 
dghr272's Avatar
 
Join Date: Jun 2012
Location: Carrickfergus NI
My Motorhome: Arapaho
Posts: 6,234
Thanks: 213
Thanked 526 Times in 491 Posts
Personal Aire
Quote:
Originally Posted by David e View Post
Hi everyone I am new to the forum can anyone tell me if I can update a EC100 Control Panel to the latest digital one please Dave
Query for Sargent I would have thought, I know some PSUs can be updated but the over door controls had to be changed as well.

Sargent customer care is really good, they'll happily advise.

Terry

'Get Brexit Done' anagram - BEING EXTORTED

I'm a Euro Unionist, Testiculi ad Brexitam

Brexit: the incapable in pursuit of the unobtainable to satisfy the delusional. (Edwin Hayward)

In the land of the blind the one-eyed man is king.
dghr272 is online now  
post #7 of 7 (permalink) Old 17-03-2019, 00:19
Senior Member
 
Join Date: Jun 2007
Location: Belfast
My Motorhome: Hymer Exsis-i 504
Posts: 7,076
Thanks: 193
Thanked 359 Times in 345 Posts
Hi David, welcome to the forum.

Did you notice there's an email for Sargent in the post above yours?

As Terry says, their customer service is known to be very good.

Jean
jiwawa is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Motorhome Forums, Motorhome Discussion, Motorhome Chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome