Advice on electrical problem in motorhome - Page 2 - Motorhome Forums, Motorhome Discussion, Motorhome Chat

User Tag List

 10Likes
Reply
 
LinkBack Thread Tools
post #11 of 31 (permalink) Old 15-10-2020, 17:19 Thread Starter
Junior Member
 
Join Date: Oct 2020
My Motorhome: I drive...
Posts: 11
Thanks: 10
Thanked 0 Times in 0 Posts
Thank you, Jean-- yep, we've pressed that one 'til we're blue in the face (ha).
Yvonne and Ward is offline  
Sponsored Links
Advertisement
 
post #12 of 31 (permalink) Old 15-10-2020, 17:56
Senior Member
 
Join Date: Jun 2007
Location: Belfast
My Motorhome: Hymer Exsis-i 504
Posts: 8,787
Thanks: 193
Thanked 470 Times in 446 Posts
I thought you probably had but best to check!

Jean
jiwawa is online now  
The Following User Says Thank You to jiwawa For This Useful Post:
Yvonne and Ward (16-10-2020)
post #13 of 31 (permalink) Old 15-10-2020, 18:01
Senior Member
 
Join Date: Jun 2007
Location: Belfast
My Motorhome: Hymer Exsis-i 504
Posts: 8,787
Thanks: 193
Thanked 470 Times in 446 Posts
What about your electroblok that controls all the 12v? Mine is under the driver's seat (LHD). Maybe a fuse gone or something popped out?

Jean
jiwawa is online now  
The Following User Says Thank You to jiwawa For This Useful Post:
Yvonne and Ward (16-10-2020)
 
post #14 of 31 (permalink) Old 15-10-2020, 18:07
Senior Member
 
rayc's Avatar
 
Join Date: Jun 2008
Location: Corfe Mullen, Wimborne Dorset
My Motorhome: Pilote 740C Sensation
Posts: 7,758
Thanks: 67
Thanked 280 Times in 255 Posts
Personal Aire
Can you confirm you have a CBE DS300 type 12v distribution box?
Attached Images
File Type: jpg cbe distribution.jpg (10.1 KB, 8 views)
rayc is offline  
The Following User Says Thank You to rayc For This Useful Post:
Yvonne and Ward (16-10-2020)
post #15 of 31 (permalink) Old 15-10-2020, 18:08
Senior Member
 
Join Date: Jun 2007
Location: Belfast
My Motorhome: Hymer Exsis-i 504
Posts: 8,787
Thanks: 193
Thanked 470 Times in 446 Posts
On page 4 of the manual available here

https://www.google.com/url?sa=t&sour..._6LBTErVqFvfrv

there is a pic of a 'tap' that governs all the 12v to the hab area.

It refers to an A class but it's possible they use the same system in others?

Jean
jiwawa is online now  
post #16 of 31 (permalink) Old 15-10-2020, 19:01 Thread Starter
Junior Member
 
Join Date: Oct 2020
My Motorhome: I drive...
Posts: 11
Thanks: 10
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by rayc View Post
Can you confirm you have a CBE DS300 type 12v distribution box?
Yes, we have a distribution box like this one, a DS304. Just in case the problem was there, I replaced all the fuses in it.
Yvonne and Ward is offline  
post #17 of 31 (permalink) Old 15-10-2020, 19:05
Senior Member
 
Join Date: Jun 2006
Location: The Berwyn mountains in the paradise of Powys
My Motorhome: Hymer S740 on Sprinter 616 (2004)
Posts: 13,577
Thanks: 232
Thanked 262 Times in 235 Posts
Glandwr is offline  
The Following User Says Thank You to Glandwr For This Useful Post:
Yvonne and Ward (16-10-2020)
post #18 of 31 (permalink) Old 15-10-2020, 20:05
Senior Member
 
rayc's Avatar
 
Join Date: Jun 2008
Location: Corfe Mullen, Wimborne Dorset
My Motorhome: Pilote 740C Sensation
Posts: 7,758
Thanks: 67
Thanked 280 Times in 255 Posts
Personal Aire
Quote:
Originally Posted by Yvonne and Ward View Post
Yes, we have a distribution box like this one, a DS304. Just in case the problem was there, I replaced all the fuses in it.
Can you remove the cover and with your multimeter check the leisure battery voltage on the large screw connectors ?
Contact -B2 is common negative.
Contact +B2 is positive leisure battery.
[Contact +B1 is positive engine battery].
Attached Images
File Type: jpg DS304SR_8a86.jpg (95.5 KB, 6 views)
rayc is offline  
The Following User Says Thank You to rayc For This Useful Post:
Yvonne and Ward (16-10-2020)
post #19 of 31 (permalink) Old 15-10-2020, 21:02
Senior Member
 
rayc's Avatar
 
Join Date: Jun 2008
Location: Corfe Mullen, Wimborne Dorset
My Motorhome: Pilote 740C Sensation
Posts: 7,758
Thanks: 67
Thanked 280 Times in 255 Posts
Personal Aire
This is the wiring diagram. As you can see there are two inputs to contact B2- and B2+. One is the leisure battery and the other the charger output. The fact that it works with the charger on but not the battery alone points to trhe leisure battery positive not getting to contact B2+. I would suspect that 50A fuse in the line from the leisure battery + to contact B2+.
Attached Images
File Type: jpg CBE DS300 wiring diagram.jpg (151.3 KB, 4 views)
eurajohn likes this.
rayc is offline  
post #20 of 31 (permalink) Old 16-10-2020, 12:17 Thread Starter
Junior Member
 
Join Date: Oct 2020
My Motorhome: I drive...
Posts: 11
Thanks: 10
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by rayc View Post
This is the wiring diagram. As you can see there are two inputs to contact B2- and B2+. One is the leisure battery and the other the charger output. The fact that it works with the charger on but not the battery alone points to trhe leisure battery positive not getting to contact B2+. I would suspect that 50A fuse in the line from the leisure battery + to contact B2+.
Thx so much for this Rayc-- when I multimeter test the leisure battery itself it reads 12.75 volts. When I took the cover off the distribution box as you suggested, the multimeter test of leisure battery through B2 bolts is only 11.37v. What does that mean to you? Again, really grateful for your know-how!
Yvonne and Ward is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Motorhome Forums, Motorhome Discussion, Motorhome Chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome