Carver fanmaster 5500 turbo - Motorhome Forums, Motorhome Discussion, Motorhome Chat

User Tag List

 
LinkBack Thread Tools
post #1 of 6 (permalink) Old 23-01-2019, 17:56 Thread Starter
Junior Member
 
Join Date: Jan 2019
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Carver fanmaster 5500 turbo

The gas and electric doesn't work. The fan is continually blowing cold air when on but nothing more and ends up tripping.

I have replaced the slider and board but no difference. Would this indicate a need to change the circuit pcu in the fire itself? There is no reset button on the back....

Please help, I don't know what to do.....

Thank you!
Mtheodorou is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 23-01-2019, 18:59
Member
 
Join Date: Nov 2016
Location: East Yorkshire
My Motorhome: I drive...Elddis Autoqueat 185
Posts: 98
Thanks: 0
Thanked 6 Times in 6 Posts
Hi, try Carver themselves as they usually have tech dept, good luck.
SteveRallye1 is offline  
post #3 of 6 (permalink) Old 23-01-2019, 20:23
Member
 
jobla's Avatar
 
Join Date: Jun 2006
Location: Washington
My Motorhome: LMC Liberty Explorer
Posts: 70
Thanks: 0
Thanked 3 Times in 3 Posts
Manual

Hi
Found this, not sure if it helps but probably worth a look if you haven't already got it.


jobla
Attached Files
File Type: pdf fanmaster.pdf (160.3 KB, 2 views)
jobla is offline  
 
post #4 of 6 (permalink) Old 23-01-2019, 20:32
Member
 
jobla's Avatar
 
Join Date: Jun 2006
Location: Washington
My Motorhome: LMC Liberty Explorer
Posts: 70
Thanks: 0
Thanked 3 Times in 3 Posts
Manual

Hi again
Attached another document which has a section on this heater which may be of interest. Also a company called Apuljack Engineering who may be able to help.


www.apuljackengineering.co.uk


Regards jobla
Attached Files
File Type: pdf 9830014_MH_Owners_Handbook_2000.pdf (1.10 MB, 1 views)
jobla is offline  
post #5 of 6 (permalink) Old 23-01-2019, 20:35 Thread Starter
Junior Member
 
Join Date: Jan 2019
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Thanks all. Tried arcsystems several times without any response so will try your advice.
Mtheodorou is offline  
post #6 of 6 (permalink) Old 24-01-2019, 07:48
Senior Member
 
Pudsey_Bear's Avatar
 
Join Date: Sep 2008
Location: Keighley, Still in Gods County.
My Motorhome: 2002 Bessacarr E745.
Posts: 36,645
Thanks: 1,464
Thanked 928 Times in 869 Posts
Send a message via AIM to Pudsey_Bear Send a message via Yahoo to Pudsey_Bear
Hi and welcome to MHF, I've no experience with this, but have a look here there are a few videos on it, one might lead to a solution.

https://www.youtube.com/results?sear...ter+5500+turbo
Pudsey_Bear is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Motorhome Forums, Motorhome Discussion, Motorhome Chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome