Hymer B544 water supply problems. - Motorhome Forums, Motorhome Discussion, Motorhome Chat

User Tag List

 1Likes
  • 2 Post By bc109
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 29-01-2018, 20:24 Thread Starter
Junior Member
 
Rabsterr's Avatar
 
Join Date: Mar 2008
Location: Whitehead Co. Antrim
My Motorhome: 2005 Hymer B544
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Personal Aire
Hymer B544 water supply problems.

Hi folks,

Iím having an ongoing problem with the water supply pumping to the taps and working fine for a while but then, after a period, every time I shut the taps the water seems to drain away and I have to prime the system again. I thought it might have been the non return valve in the reich pump and when I inspected it it seemed to be sticking. I replaced the pump but Iím having the same problem again. Could it be a faulty pump? It seems unlikely so what could it be? Has anyone else had a similar problem?

Any help would be appreciated.
Cheers ,

Robert

Rabsterr is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 29-01-2018, 20:56
Senior Member
 
Join Date: Sep 2016
Location: Costa Blanca Spain
My Motorhome: I drive... Hymer B550 Skyline
Posts: 265
Thanks: 50
Thanked 38 Times in 38 Posts
An additional non-return valve in the feed pipe on top of the tank ( very cheap fix ) should prove beneficial.
Otherwise, look for a water leak inside the accommodation or outside on the ground !
Bill
dghr272 and dghr272 like this.
bc109 is offline  
post #3 of 4 (permalink) Old 29-01-2018, 20:59
Senior Member
 
Drew's Avatar
 
Join Date: May 2005
Location: Bridport, Dorset
Posts: 4,331
Thanks: 164
Thanked 211 Times in 198 Posts
I believe it to be the non return valve OR you may have a leak somewhere in the system.

Loch Sloy
This I'll Defend


I would prefer to say that I am British rather than European.
Drew is offline  
 
post #4 of 4 (permalink) Old 30-01-2018, 07:41 Thread Starter
Junior Member
 
Rabsterr's Avatar
 
Join Date: Mar 2008
Location: Whitehead Co. Antrim
My Motorhome: 2005 Hymer B544
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Personal Aire
Thanks for the replies. Iíve ordered an in-line non return valve to see if that helps and Iíll keep a look out for leaks. Fingers crossed!

Rabsterr is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Motorhome Forums, Motorhome Discussion, Motorhome Chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome