CI Mizar 2007+ - Motorhome Forums, Motorhome Discussion, Motorhome Chat

User Tag List

Reply
 
LinkBack Thread Tools
post #1 of 20 (permalink) Old 24-10-2008, 22:17 Thread Starter
Senior Member
 
Join Date: Jan 2008
Location: Norwich
Posts: 131
Thanks: 0
Thanked 0 Times in 0 Posts
CI Mizar 2007+

Hi

Are there any other owners of a CI Mizar (all variants) 2007+ out there?

What problems if any have you encountered?

How long have you waited for spares?

All replies will be gratefully received!
stevenjonathan is offline  
Sponsored Links
Advertisement
 
post #2 of 20 (permalink) Old 20-11-2008, 23:19 Thread Starter
Senior Member
 
Join Date: Jan 2008
Location: Norwich
Posts: 131
Thanks: 0
Thanked 0 Times in 0 Posts
Anyone?
stevenjonathan is offline  
post #3 of 20 (permalink) Old 20-11-2008, 23:24
Senior Member
 
Join Date: Jul 2007
Location: Suffolk
Posts: 377
Thanks: 0
Thanked 0 Times in 0 Posts
Not exactly a Mizar but we did have a 2007 Carioca 705 (same dog , different lampost) and had no problems whatsoever in the 13 months we had it.

Steve and Ian
suffolkian is offline  
 
post #4 of 20 (permalink) Old 20-11-2008, 23:39
Senior Member
 
Imbiber's Avatar
 
Join Date: May 2007
Location: West Yorkshire
My Motorhome: Eura Mobil Activa 820 HS
Posts: 471
Thanks: 18
Thanked 38 Times in 19 Posts
Personal Aire
Hi, we got a new GTL Living in June...and are very happy with it.

Apart from the odd little niggle (not on the "Lunar Scale" by any means; can I copywright that as a new measure of disatisfaction?), we,ve put up with the way problems are resolved in this industry - slow!

Had a new garage door on order...8 weeks gone still no news...but it ain't stoppin us from using it!

Other points of note:

1. Ours lacks extra battery capacity as the cradle under the van is small; we'll look into remedying this though; possibly through a 'Greenie Box'!

2. If you have an integrated step with a grill in the bottom step you're likely to experience water ingress from the road. A simple baffle plate underneath can be fitted to remedy this problem though.

3. They have an extremely flat roof; particularly where the overcab section joins the main roof section. Watch out for large puddles of standing water collecting here.

4. I found early on that any problem I felt the dealer was not likely to assist me with, going straight to Trigano in Grimsby was a better option. The CI guys there were really helpful and even got me my fancy kitchen plug thing from Italy for me...had to wait 8 weeks for it though!

Hope this helps. If I think of anything more I'll keep you informed. If you want to ask anything specific just pm me!
Imbiber is offline  
post #5 of 20 (permalink) Old 20-11-2008, 23:39
Senior Member
 
Join Date: Sep 2007
Location: Bedfordshire
My Motorhome: 2015 Bailey Approach Autograph 740
Posts: 5,965
Thanks: 0
Thanked 2 Times in 2 Posts
Main issue with CI is damp ahead of the side windows. They have always been bad for spares, but so has the whole industry.
The entire caravan and motorhome industry seems to think that it is acceptable to make customers wait a minimum of 6 weeks for parts. Always been the same. Part of the joy of buying into a 1billion cottage industry.
Gerry
GerryD is offline  
post #6 of 20 (permalink) Old 21-11-2008, 00:43 Thread Starter
Senior Member
 
Join Date: Jan 2008
Location: Norwich
Posts: 131
Thanks: 0
Thanked 0 Times in 0 Posts
Thanks Imbiber

I have the Mizar G Living which we bought last February. All has been relatively well apart fom a few niggles. I have been through the whole van and tightened everything up as all appeared to be a bit loose - probably just wearing in.

I too have the step water problem but solved this by (wait for it) duck taping the vent shut - stops the cold draught too!

Have noticed the water collecting on the roof - will watch the sealant!

I had a decal missing above the gas locker door which I ordered through the dealer on FEBRUARY 14th and am still waiting! I also ordered a new table as it had delaminated just above the screw which tightens it up back in August and am still waiting for that too - they are extremely slow aren't they?!

I had an extra battery fitted and wanted another cradle fitted but at apparently 800 didn't bother! I changed the original 85Amp for a 110 and it will fit in the cradle but will not wind up as far as it should. I have secured and blocked it from coming back down by severely tightening the stop screws against the sides and all has been fine. (If you do this make sure you cover the +ve terminal as it will short out on the chassis otherwise) The dealer then managed to fit the 85A under the offside rear seat and all is now well with power. The cradle thing is a stupid idea they would have been better off putting it in the garage or something.

I find that the gas strut on the door is too weak - almost no resistance at all. At the weekend the wind took the door and it cracked the exterior trim behind the bottom hinge when it collided - apparently these stuts are all weak and will be on the lookout either for a regas or different strut - be careful of yours especially when windy!!

Another problem was water appearing from under the bathroom wall, turns out that the plate that the tap sits on in the shower wasn't sealed - worth checking yours as there is a great big hole under that plate!

The rear suspension creaks like crazy on bumpy roads - surely should not be like this - will attack with some grease....

Apart from these niggles have been really pleased with it - it has now done just under 14000 miles since Feb and is still in one piece...
stevenjonathan is offline  
post #7 of 20 (permalink) Old 21-11-2008, 10:15
Senior Member
 
Imbiber's Avatar
 
Join Date: May 2007
Location: West Yorkshire
My Motorhome: Eura Mobil Activa 820 HS
Posts: 471
Thanks: 18
Thanked 38 Times in 19 Posts
Personal Aire
14K since Feb...good going; you're certainly getting use out of it. We're nearly 7K since June and really pleased with it.

Thank's for the head's up on wind and battery issues...I need to get hold of a tool that will wind the cradle down...mine didn't come with one!

So the extra battery has gone next to the water tank then?
Imbiber is offline  
post #8 of 20 (permalink) Old 21-11-2008, 11:11 Thread Starter
Senior Member
 
Join Date: Jan 2008
Location: Norwich
Posts: 131
Thanks: 0
Thanked 0 Times in 0 Posts
I can't think what layout the front of a GTL has got? I think it's almost the same as mne - the water tank being under the rear travelling seats?

The battery has been located under the seat which sits sideways behind the drivers seat, on top of the gas locker. Under the cushions I have 2 flaps and its in the front part of the right hand flap towards the front of the compartment. Its a tight squeeze but great because it cant't move about.

If you want any photos PM me - it's the only other place a battery would go without trailing wires too far.
stevenjonathan is offline  
post #9 of 20 (permalink) Old 23-11-2008, 17:30
Junior Member
 
Join Date: Nov 2008
Location: North west england
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
As a Ci dealer I can tell you spares have been a problem. However now all Ci dealers are linked by computer to the CI spares web site in Italy. In the past it has taken around 6 months to obtain a water tank. We ordered one last week and were amazed when it arrived 7 days later. Better than most UK manufacturers!
emmbee1 is offline  
post #10 of 20 (permalink) Old 13-04-2011, 22:35
Junior Member
 
Join Date: Jul 2010
Location: West Yorkshire
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
I have purchased a Mizar and cannot find the winder for the utility battery tray.. Where is it stored?
Where can i get a new one if it turns out to be missing? Or is there something else i can use to wind it down??

I also need a few other parts...

* Need the bottom part of the roof ladder
* Need Adapter for external gas point (to attach to my BBQ)
* got a list of other bits in the van... will dig it out!

I also have a few niggles.....

* The leisure battery goes flat if left on my drive for a few days (everything is off)
* The extra security lock on the garage door is jammed, the key will not turn the lock
* The front skylight winds shut but doesn't seal against the rubber
* I cannot get the digital TV to work? No signal on screen but the digital aerial is switched on and works for analogue tv?
* Leisure battery doesn't charge when driving? Just on hookup to mains?
* I am getting alarms on the panel saying S1 0% S2 0%... I think this is water tank sensor but there is water in it? Is this because i am on a slope?


I have other things but will post them later.. Dont want to post too much in one go!?

Can anyone offer any advice?

Where do you get spares at a reasonable price?

Thanks
arjxh56 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Motorhome Forums, Motorhome Discussion, Motorhome Chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome