CBE control panel won’t stay on - Rapiddo 9F - Motorhome Forums, Motorhome Discussion, Motorhome Chat

User Tag List

 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 30-10-2020, 00:27 Thread Starter
RRW
Junior Member
 
Join Date: Oct 2020
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
CBE control panel won’t stay on - Rapiddo 9F

Hi. Batteries are fully charged and showing good voltage, however CBE panel (PC200RO + DS520RA) is off. If I push and hold the standby button it comes back to life and all functions work, lights, aux, water pump etc. As soon as I remove my finger from the standby button the control panel dies. I’ve also plugged into mains at home and left on mains power. Same issue. Nothing left plugged in, fuse box not tripped. Any ideas/recommendations?
RRW is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 30-10-2020, 17:41
Senior Member
 
Mrplodd's Avatar
 
Join Date: Mar 2008
Location: Weymouth
My Motorhome: A Caravan of all things !!
Posts: 9,384
Thanks: 116
Thanked 528 Times in 450 Posts
Sounds like the control panel is dying as it doesnít seem to know it should stay switched on! Just a guess.

Do the lights etc stay on when the panel goes dark or does everything switch off?

Its not the destination that matters.

It's who you share the journey with (even if like me, itís in a caravan!)
I am very fortunate to have Mrs Plodd to share mine with
Mrplodd is offline  
post #3 of 4 (permalink) Old 30-10-2020, 19:37 Thread Starter
RRW
Junior Member
 
Join Date: Oct 2020
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
If I push and hold the standby button everything switches on. Soon as I let go everything, including lights, turns off.
RRW is offline  
 
post #4 of 4 (permalink) Old 30-10-2020, 19:59
Senior Member
 
rayc's Avatar
 
Join Date: Jun 2008
Location: Corfe Mullen, Wimborne Dorset
My Motorhome: Pilote 740C Sensation
Posts: 7,758
Thanks: 67
Thanked 280 Times in 255 Posts
Personal Aire
Quote:
Originally Posted by RRW View Post
If I push and hold the standby button everything switches on. Soon as I let go everything, including lights, turns off.
I think the switch applies battery volts to a 'Fiche Electronic' chip in the control unit which electronically latches it on. The next press of the switch unlatches it. I do not think the switch itself is a latching type but your description of what happens indicates it could be and it just isn't latching? I have attached a pdf schematic of the control box and distribution box which shows the on/off switch connected to the 'Fiche Electronic'.

Marcel Leisure have been supplying CBE systems for many years and may be able to advise you further https://www.marcleleisure.co.uk/
Attached Files
File Type: pdf man_cbe_pc.PDF.pdf (43.8 KB, 3 views)

Last edited by rayc; 30-10-2020 at 20:06.
rayc is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Motorhome Forums, Motorhome Discussion, Motorhome Chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome