Dead Battery, Dead Charger or both - Page 2 - Motorhome Forums, Motorhome Discussion, Motorhome Chat

User Tag List

 4Likes
Reply
 
LinkBack Thread Tools
post #11 of 12 (permalink) Old 26-08-2020, 12:35
EJB
Senior Member
 
EJB's Avatar
 
Join Date: Aug 2007
Location: Suffolk (By choice)
My Motorhome: Burstner Nexxo t620G
Posts: 4,223
Thanks: 30
Thanked 132 Times in 122 Posts
Any excuse!!!

Ted.
I try and state simple facts in a nice way.
EJB is offline  
Sponsored Links
Advertisement
 
post #12 of 12 (permalink) Old 31-08-2020, 17:12 Thread Starter
Junior Member
 
Join Date: Apr 2018
My Motorhome: I drive...
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Thanks to all for their replies. I have been away without Internet access for the last week, so have not been to reply sooner.

I thought I would feedback a few of my own thoughts and findings, in case they of use to others.

With the leisure battery disconnected it read 5.5v; well flat! I put it on charge using old car battery charger for several days, where it pulled 5amps for around 24hrs , then gradually dropped to approx 2 amps. After disconnecting the charger it has been gradually losing charge at 0.1v every couple of minutes. Looks like the battery is totally kaput.

Re the alarm - it is powered from the base vehicle battery, however I wondered that with leisure battery being totally flat there has been a significant voltage drop across the battery to battery connection, which triggered the alarm. After the engine had been running for a couple of minutes and the leisure battery was totally isolated, the alarm stopped.

On fitting a new leisure battery I also discovered that an in line fuse in one of the two pairs of wires connected to the leisure battery had blown; but don't know why. Perhaps one set is on the charging side and this is the one that had blown, then the battery was discharging while not charging, with the obvious consequences.

I hope that my summation could help anyone else that may experience a similar situation. Thanks again.
eurajohn, raynipper and bc109 like this.
Michael1949 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Motorhome Forums, Motorhome Discussion, Motorhome Chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome