Mercedes Sprinter Fuse Chart/Numbers - Page 2 - Motorhome Forums, Motorhome Discussion, Motorhome Chat

User Tag List

Reply
 
LinkBack Thread Tools
post #11 of 19 (permalink) Old 10-05-2010, 00:32
Junior Member
 
Join Date: Apr 2010
Location: Surrey
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Long story but I had a problem where after driving 2 hours van refused to start. called AA. all dash lights come up but turned key and nothing happened. AA spent 2 hours checking and eventually jump started direct to starter motor with ignition turned on. (This is an automatic) Heater fan etc failed to operate from that time.
Drove 70 miles home and stopped Started again no problem. Two days later same starting problem. Next day started no problem but Fan/heater still not working. have started a 20+ times since then and no problem except for the fan/heater/ac
Have checked all fuses with multimeter and all are OK.. Unfortunately it is a Rimor and only had 2 yrs warranty. Is the CAN Bus the black box fitted to the side of the fuse box
Thks for your help
jagmad is offline  
Sponsored Links
Advertisement
 
post #12 of 19 (permalink) Old 10-05-2010, 17:38
Senior Member
 
Join Date: May 2005
Posts: 2,023
Thanks: 81
Thanked 98 Times in 93 Posts
OUCH !


your original problem was that the van wouldn't start you say the lights came on but the engine didn't turn over !

were there any errors or messages showing in the dash display ?

& the AA got the engine going by jump starting directly to the starter motor and not to the jump start connections in the engine bay

did the AA suspect a problem with your battery?
and if it has happened again how did you start it the second time?


jump starting modern vehicles with engine management systems has been known to cause all sorts of problems with the electrical systems- a surge or spike in voltage can damage your electronic circuits

Could be worth complaining to the AA that they have caused damage to your vehicle by jump starting it

personally I wouldn't have let them jump start it but insist on recovery

just do a search on the web for :- jump start ecu failure

It may be worth disconnecting your engine battery overnight
but again I think a trip to a MB dealership or a MB independant specialist is in order to put it on the STAR diagnostics computer
trek is offline  
post #13 of 19 (permalink) Old 10-05-2010, 17:58
Senior Member
 
Join Date: May 2005
Posts: 2,023
Thanks: 81
Thanked 98 Times in 93 Posts
check out this USA forum

this guy has recently posted a similar problem - his lights & wipers wont work following a jump start


http://sprinter-source.com/forum/showthread.php?t=10986

no fix posted yet but his email is on the thread so you could ask him what he has done ?


Could also be worth you contacting a local specialist if you can find one
Eg:-
http://www.williamsdiesels.com/
trek is offline  
 
post #14 of 19 (permalink) Old 10-05-2010, 20:34
Junior Member
 
Join Date: Apr 2010
Location: Surrey
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
I tried to shorten the whole story in fact 5 days before the jump start on my way to the camp site was the start of my problem. Stopped for a cuppa and could not start. Everthing worked except the starter did not resond to the key turn. AA on this occaision checked everthing and tried starting at least 20 times. He was calling the recovery truck and I had one last try and it started. Everything worked. Drove around for 5 days then on the way home I stopped for a cuppa and the start problem re-occured. On this occaision the AA man jump started by connecting direct to the starter. My battery was fully charged and connected. As this was a few weeks ago I dont think I can complain to AA unless I find that it was the cause of the failure of the Fan/heater/ac. There were no errors showing on the dash. He tried connecting to my charging point but got no response. I assume the power was not reaching the starter motor or the signal from the ignition key was not getting any response from the ECU
I will have to give in and visit my local independant he has the star diagnostics. I will let you know the outcome.
I will e-mail the guy on the US forum and see how he solved his problem I did disconnect the battery for an hour but I will leave it off overnight to see if anything resets.
Thanks fo all you helpful suggestions
jagmad is offline  
post #15 of 19 (permalink) Old 10-05-2010, 21:05
Senior Member
 
Join Date: May 2005
Posts: 2,023
Thanks: 81
Thanked 98 Times in 93 Posts
goodluck & fingers crossed for you

Tip :-

Mercedes commercial dealers are open much longer hours than normal car dealers often they work shifts from say 6am to midnight some even work 24 hours a day during the week to meet the needs of commercial vehicles .

As a result it could be worth calling the nearest dealer to you for advice if you have trouble no matter what time of day?


Same goes for IVECO campers

I once had trouble at 2am on the Motorway heading home after leaving Dover with my Iveco camper
The turbo pipe had blown off & I couldn't get the clip back on to the intercooler, anyway we rang the local Iveco dealer whose recorded announcement was advising callers of office hours but just as I was about to hang up it told me to hold for out of hours service, they told me to pop in & they fitted a new large jubilee clip - cost me a box of the beer I had brought from France
trek is offline  
post #16 of 19 (permalink) Old 28-07-2011, 01:26
Junior Member
 
Join Date: Jul 2011
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
hi there


at my works they cant be bothered to fix the radio that aint working in the 313 eco start Mercedes sprinter so i wondering if anyone knows what might be the problem.

the cigarette lighter works and about everything else does but no cd player/radio at all ? is there a fuse diagram someone could email me

cheers
unclegusy2k is offline  
post #17 of 19 (permalink) Old 28-07-2011, 07:05
Member
 
Join Date: May 2005
Location: South Wales
Posts: 93
Thanks: 0
Thanked 0 Times in 0 Posts
Hi Jagmad, had a similar problem with mine, it occaisionly did,nt turn over from new but always started, it was so quiet though, I put it down to my lack of familiarity with it. However, on taking it back to the dealer for it 1st year check up it failed completely outside the gates where we had spent the night! Their mechanic came out and had it going again in two minutes, a faulty solenoid being the cause, the whole thing(startrer inc' ) was replaced under warranty and no further trouble three years on. This fault would'nt have shown up on a diagnostic check.
Mike
MiketheWelshman is offline  
post #18 of 19 (permalink) Old 28-07-2011, 16:52
Senior Member
 
Join Date: May 2005
Posts: 2,023
Thanks: 81
Thanked 98 Times in 93 Posts
Hi unclegusy2k

looks like the radio shares fuse 13 with the ciggy lighter & glove box (glove box light I assume)

so you say the ciggy lighter works - what about the glove box light?

time to pull out the radio & check the connections on the rear

some radios will have an inline fuse in the power feed or a fuse at the rear or inside the radio so worth checking these

do you have a multimeter or test lamp check the radios 12v feeds & earth connections.

is it a factory fitted merc radio or aftermarket.

the radio will have two 12v inputs one to keep power to the unit to save the programmed info the other usually switched via the ignition to turn it on for normal use.
trek is offline  
post #19 of 19 (permalink) Old 13-09-2015, 02:03
Junior Member
 
Join Date: Sep 2015
My Motorhome: I drive...
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Can anyone give me the location for the tail light fuse on a Sprinter Solera 2015 RV? Thanks!
Martin Johnson is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Motorhome Forums, Motorhome Discussion, Motorhome Chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome