Ducato error code P0697 dealer canít fix it - Motorhome Forums, Motorhome Discussion, Motorhome Chat

User Tag List

 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 03-07-2021, 19:29 Thread Starter
Senior Member
 
Join Date: May 2005
Posts: 2,036
Thanks: 83
Thanked 101 Times in 96 Posts
Ducato error code P0697 dealer canít fix it

Any one had experience of a ducato with a DTC error code of P0697

It appears to refer to :-The Engine Control Module (ECM) has detected an out of voltage range on the 5 volt reference circuit 3 or circuit C


Fiat independent specialist garage has failed to find the fault on numerous occasions



Anyone with a circuit diagram of the ECU so we can try to find out what circuit 3 (or C) is and what modules are connected to it ?
trek is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 03-07-2021, 22:38
Senior Member
 
Mrplodd's Avatar
 
Join Date: Mar 2008
Location: Weymouth
My Motorhome: A Caravan of all things !!
Posts: 9,541
Thanks: 121
Thanked 545 Times in 466 Posts
Might be worth contacting Fiat customer service dept to see what they say. I would be inclined to tell them that one of Their main dealers cannot diagnose the fault.

Out of interest what are the symptoms of the fault??

Its not the destination that matters.

It's who you share the journey with (even if like me, itís in a caravan!)
I am very fortunate to have Mrs Plodd to share mine with
Mrplodd is offline  
post #3 of 4 (permalink) Old 03-07-2021, 22:43
Senior Member
 
rayc's Avatar
 
Join Date: Jun 2008
Location: Corfe Mullen, Wimborne Dorset
My Motorhome: Pilote 740C Sensation
Posts: 7,887
Thanks: 68
Thanked 294 Times in 268 Posts
Personal Aire
It may be worth asking on here https://www.fiatforum.com/ducato/
rayc is offline  
 
post #4 of 4 (permalink) Old 03-07-2021, 23:39 Thread Starter
Senior Member
 
Join Date: May 2005
Posts: 2,036
Thanks: 83
Thanked 101 Times in 96 Posts
Either warning light comes on when starting engine which struggles to idle and radiator fan running full pelt

Or it comes on while driving , goes into limp mode while cruise control and hill hold stop working

Fault is intermittent was at garage for days where they checked connectors and sensors and earths and all was well when it left them but following morning fault reappeared on drive at home when first started

Had already searched fiat forum and found some things to look at but not posted on there (yet)

Thanks
trek is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Motorhome Forums, Motorhome Discussion, Motorhome Chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome