2012 Fiat Ducato 3.0 - Keeps going into limp mode... please help - Motorhome Forums, Motorhome Discussion, Motorhome Chat

User Tag List

 8Likes
Reply
 
LinkBack Thread Tools
post #1 of 18 (permalink) Old 15-12-2019, 13:24 Thread Starter
Junior Member
 
Join Date: Dec 2019
My Motorhome: I drive...
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy 2012 Fiat Ducato 3.0 - Keeps going into limp mode... please help

Hello,


The camper van (3.0l - 180) is constantly going into limp mode, I've replaced number 2 injector and injector plugs, now the fault has moved to cylinder 4 which making me think it could be a wiring fault instead of an injector fault.


I had the following error codes:


P0271 - CYLINDER 4 INJECTOR
P0265 - CYLINDER 2 INJECTOR
P0268 - CYLINDER 3 INJECTOR


I cleared the codes and it repeated cylinder 2 injector fault so I replaced it and now the problem has moved to cylinder 4...


Has anyone ever had this trouble? I'm thinking I should replace the wiring loom next.



Only 15,000km on the van :/


Any help apprecaited.
roy660 is offline  
Sponsored Links
Advertisement
 
post #2 of 18 (permalink) Old 15-12-2019, 13:31
Senior Member
 
JanHank's Avatar
 
Join Date: Mar 2015
Location: East Germany, I can see Poland from my windows.
My Motorhome: I drive...Auto Trail Navajo
Posts: 9,932
Thanks: 441
Thanked 554 Times in 499 Posts
Personal Aire
I canīt help, I just wish I knew what limp mode means ???

I'm Jan
We learn something new every day.
JanHank is online now  
post #3 of 18 (permalink) Old 15-12-2019, 13:49
Senior Member
 
rayc's Avatar
 
Join Date: Jun 2008
Location: Corfe Mullen, Wimborne Dorset
My Motorhome: Pilote 740C Sensation
Posts: 7,522
Thanks: 67
Thanked 255 Times in 233 Posts
Personal Aire
Is there any chance that scuttle leakage could be allowing water onto the harness?
rayc is online now  
 
post #4 of 18 (permalink) Old 15-12-2019, 13:57 Thread Starter
Junior Member
 
Join Date: Dec 2019
My Motorhome: I drive...
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by rayc View Post
Is there any chance that scuttle leakage could be allowing water onto the harness?



I have lots of water around my injectors and there seems to be some leakage around the scuttle, has anyone ever replaced the harness because of this?
roy660 is offline  
post #5 of 18 (permalink) Old 15-12-2019, 14:18
Senior Member
 
KeithChesterfield's Avatar
 
Join Date: Mar 2010
Location: Guess!
My Motorhome: Pilote Reference P716
Posts: 3,178
Thanks: 57
Thanked 139 Times in 93 Posts
Personal Aire
Do you have any other issues - such as Dashboard lights on that shouldn't be ?
roy660 likes this.

For Videos of the Aires we've used, Eurotunnel journeys and many other more obscure Videos have a look at - www.youtube.com/user/KeithChesterfield

For Recommended Vets in Europe have a look at - https://www.google.com/maps/d/viewer?msa=0&mid=zTPBDq9Df4L4.kSm3eLuvVb2g
KeithChesterfield is online now  
post #6 of 18 (permalink) Old 15-12-2019, 15:04 Thread Starter
Junior Member
 
Join Date: Dec 2019
My Motorhome: I drive...
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
hi just engine management light
roy660 is offline  
post #7 of 18 (permalink) Old 15-12-2019, 16:12
Senior Member
 
Join Date: May 2005
Posts: 1,997
Thanks: 73
Thanked 91 Times in 86 Posts
Could be the injector wiring / connection terminals

Maybe a common problem for a certain range of engines ? Cos we did hear others with same problem back some 5 years or so

Mate had ongoing trouble wiggling connectors on top of one of the injectors seemed to cure it until
the next time

Eventually sorted it by fitting a 2nd hand bit of the loom that feeds the injectors
trek is offline  
post #8 of 18 (permalink) Old 15-12-2019, 16:27 Thread Starter
Junior Member
 
Join Date: Dec 2019
My Motorhome: I drive...
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
i did replace the plugs on top of injectors but with cheap ebay ones i was thinking of getting 4 new ones of fiat and change them again ?
roy660 is offline  
post #9 of 18 (permalink) Old 15-12-2019, 17:15
Senior Member
 
Join Date: Jun 2007
Location: Belfast
My Motorhome: Hymer Exsis-i 504
Posts: 7,241
Thanks: 193
Thanked 368 Times in 354 Posts
Quote:
Originally Posted by JanHank View Post
I canīt help, I just wish I knew what limp mode means ???
When the engine loses power and just limps along. I've had lots of experience!!
JanHank and roy660 like this.

Jean
jiwawa is offline  
post #10 of 18 (permalink) Old 15-12-2019, 17:20
Senior Member
 
JanHank's Avatar
 
Join Date: Mar 2015
Location: East Germany, I can see Poland from my windows.
My Motorhome: I drive...Auto Trail Navajo
Posts: 9,932
Thanks: 441
Thanked 554 Times in 499 Posts
Personal Aire
Quote:
Originally Posted by jiwawa View Post
When the engine loses power and just limps along. I've had lots of experience!!
Thanks Jean. I wonder why one of the men didn't answer me, perhaps they thought I was using the double meaning 😂 me being me.

I'm Jan
We learn something new every day.
JanHank is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Motorhome Forums, Motorhome Discussion, Motorhome Chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome