Motorhome Forums, Motorhome Discussion, Motorhome Chat

Motorhome Forums, Motorhome Discussion, Motorhome Chat (https://forums.motorhomefacts.com/)
-   Fiat Ducato (https://forums.motorhomefacts.com/149-fiat-ducato/)
-   -   2012 Fiat Ducato 3.0 - Keeps going into limp mode... please help (https://forums.motorhomefacts.com/149-fiat-ducato/237751-2012-fiat-ducato-3-0-keeps-going-into-limp-mode-please-help.html)

roy660 15-12-2019 12:24

2012 Fiat Ducato 3.0 - Keeps going into limp mode... please help
 
Hello,


The camper van (3.0l - 180) is constantly going into limp mode, I've replaced number 2 injector and injector plugs, now the fault has moved to cylinder 4 which making me think it could be a wiring fault instead of an injector fault.


I had the following error codes:


P0271 - CYLINDER 4 INJECTOR
P0265 - CYLINDER 2 INJECTOR
P0268 - CYLINDER 3 INJECTOR


I cleared the codes and it repeated cylinder 2 injector fault so I replaced it and now the problem has moved to cylinder 4...


Has anyone ever had this trouble? I'm thinking I should replace the wiring loom next.



Only 15,000km on the van :/


Any help apprecaited.

JanHank 15-12-2019 12:31

I can´t help, I just wish I knew what limp mode means ???

rayc 15-12-2019 12:49

Is there any chance that scuttle leakage could be allowing water onto the harness?

roy660 15-12-2019 12:57

Quote:

Originally Posted by rayc (Post 3064439)
Is there any chance that scuttle leakage could be allowing water onto the harness?




I have lots of water around my injectors and there seems to be some leakage around the scuttle, has anyone ever replaced the harness because of this?

KeithChesterfield 15-12-2019 13:18

Do you have any other issues - such as Dashboard lights on that shouldn't be ?

roy660 15-12-2019 14:04

hi just engine management light

trek 15-12-2019 15:12

Could be the injector wiring / connection terminals

Maybe a common problem for a certain range of engines ? Cos we did hear others with same problem back some 5 years or so

Mate had ongoing trouble wiggling connectors on top of one of the injectors seemed to cure it until
the next time

Eventually sorted it by fitting a 2nd hand bit of the loom that feeds the injectors

roy660 15-12-2019 15:27

i did replace the plugs on top of injectors but with cheap ebay ones i was thinking of getting 4 new ones of fiat and change them again ?

jiwawa 15-12-2019 16:15

Quote:

Originally Posted by JanHank (Post 3064435)
I can´t help, I just wish I knew what limp mode means ???

When the engine loses power and just limps along. I've had lots of experience!!

JanHank 15-12-2019 16:20

Quote:

Originally Posted by jiwawa (Post 3064513)
When the engine loses power and just limps along. I've had lots of experience!!

Thanks Jean. I wonder why one of the men didn't answer me, perhaps they thought I was using the double meaning 😂 me being me.


All times are GMT +1. The time now is 15:48.

Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.

vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

 
For the best viewing experience please update your browser to Google Chrome