2012 Fiat Ducato 3.0 - Keeps going into limp mode... please help - Page 3 - Motorhome Forums, Motorhome Discussion, Motorhome Chat

User Tag List

 10Likes
Reply
 
LinkBack Thread Tools
post #21 of 25 (permalink) Old 13-03-2020, 20:07
Junior Member
 
Join Date: Mar 2020
My Motorhome: I drive...
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by KeithChesterfield View Post
Are there any other lights showing on the dashboard that shouldn't be - that would indicate a possible fault with the ECU which is a well known problem with Ducato of that age.

No Keith just the red engine light ;-/
KeithChesterfield likes this.
Cirmo is offline  
Sponsored Links
Advertisement
 
post #22 of 25 (permalink) Old 24-08-2020, 11:17
Junior Member
 
Mistyblu14's Avatar
 
Join Date: Mar 2019
My Motorhome: I drive...
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
I have the same code P0271 cyclinder 4 over voltage. Wiring loom all tested OK, connections all cleaned and engineer is awaiting new brake switch from Fiat as it only happens when using cruise control. In 1,000 miles activated twice. Reset on road with OBF11 unit so can carry on.
Let’s see what happens after new switch is fitted.
Mistyblu14 is offline  
post #23 of 25 (permalink) Old 24-08-2020, 17:36
Senior Member
 
Join Date: Jun 2007
Location: Belfast
My Motorhome: Hymer Exsis-i 504
Posts: 8,787
Thanks: 193
Thanked 470 Times in 446 Posts
Fingers crossed that works mistyblu - these problems seem very hard to solve.

And welcome to the forum!

Jean
jiwawa is online now  
 
post #24 of 25 (permalink) Old 07-11-2020, 09:56
Junior Member
 
Mistyblu14's Avatar
 
Join Date: Mar 2019
My Motorhome: I drive...
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
3 litre engine. Iveco unit.
Injector 4 replaced after specialist pneumatic tool used and then two weeks later replaced the other three injectors all extracted by specialist as on 15,500 miles and condition of them look like they have been in there for millions of years and totally rusted in.
Done over 1,000 miles with no high voltage faults now. 😃
Previous owner took no action on scuttle leak and only did 600 miles in a year.
Upgrades have included engine cover from Slovakia, scuttle drainage under tray from Citroen part 6454.66 but had to move brake boost system to new location, extra scuttle drainage using 10mm brake pipe.
Going to fit and seal a drip tray to behind nsf headlight above wiring loom and fuse box to catch rain drip from nsf windscreen
Shouldn’t have to do this but better than allowing rain onto loom
SHAME ON FIAT FOR ALLOWING BAD DESIGN.
eurajohn likes this.
Mistyblu14 is offline  
post #25 of 25 (permalink) Old 09-11-2020, 13:23
Senior Member
 
Join Date: Jun 2007
Location: Belfast
My Motorhome: Hymer Exsis-i 504
Posts: 8,787
Thanks: 193
Thanked 470 Times in 446 Posts
Fingers crossed all sorted now.

Jean
jiwawa is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Motorhome Forums, Motorhome Discussion, Motorhome Chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome