2012 Fiat Ducato 3.0 - Keeps going into limp mode... please help - Page 2 - Motorhome Forums, Motorhome Discussion, Motorhome Chat

User Tag List

 9Likes
Reply
 
LinkBack Thread Tools
post #11 of 21 (permalink) Old 15-12-2019, 16:21
Senior Member
 
Join Date: Jun 2007
Location: Belfast
My Motorhome: Hymer Exsis-i 504
Posts: 7,746
Thanks: 193
Thanked 404 Times in 385 Posts
Ah well, you see, having made your bed....
JanHank likes this.

Jean
jiwawa is offline  
Sponsored Links
Advertisement
 
post #12 of 21 (permalink) Old 15-12-2019, 16:35
Senior Member
 
eurajohn's Avatar
 
Join Date: May 2005
Location: Mayenne France
My Motorhome: Frankia T640 FF2
Posts: 3,103
Thanks: 49
Thanked 208 Times in 185 Posts
Did you replace the injector with a new or used item?

.

John
eurajohn is offline  
post #13 of 21 (permalink) Old 15-12-2019, 16:50
Senior Member
 
dghr272's Avatar
 
Join Date: Jun 2012
Location: Carrickfergus NI
My Motorhome: Arapaho
Posts: 6,982
Thanks: 247
Thanked 578 Times in 540 Posts
Personal Aire
Quote:
Originally Posted by JanHank View Post
Thanks Jean. I wonder why one of the men didn't answer me, perhaps they thought I was using the double meaning 😂 me being me.
I must say, I resemble that remark.

Terry
JanHank likes this.

The people who passed off a pair of gloves as *two* items of PPE may not be entirely honest.

'Get Brexit Done' anagram - BEING EXTORTED

I'm a Euro Unionist, Testiculi ad Brexitam

Brexit: the incapable in pursuit of the unobtainable to satisfy the delusional. (Edwin Hayward)

In the land of the blind the one-eyed man is king.
dghr272 is offline  
 
post #14 of 21 (permalink) Old 15-12-2019, 18:08
Senior Member
 
rayc's Avatar
 
Join Date: Jun 2008
Location: Corfe Mullen, Wimborne Dorset
My Motorhome: Pilote 740C Sensation
Posts: 7,653
Thanks: 67
Thanked 265 Times in 242 Posts
Personal Aire
Quote:
Originally Posted by roy660 View Post
I have lots of water around my injectors and there seems to be some leakage around the scuttle, has anyone ever replaced the harness because of this?
I suggest as a first step removing the lead from the injector and completely drying it out the plug /socket with a hair dryer.
HurricaneSmith likes this.
rayc is offline  
post #15 of 21 (permalink) Old 16-12-2019, 08:11
Senior Member
 
eurajohn's Avatar
 
Join Date: May 2005
Location: Mayenne France
My Motorhome: Frankia T640 FF2
Posts: 3,103
Thanks: 49
Thanked 208 Times in 185 Posts
Another question, when you changed the connector plugs did you use the ones with wires attached and make joints on wires?
Or remove the old plug and re-use the original pin?
Or remake the assembly completely with new plug and pins?

The system requires secure electrical connections to function properly, if you have made poor joints that could be the cause of your problem.

.

John
eurajohn is offline  
post #16 of 21 (permalink) Old 16-12-2019, 09:18
Senior Member
 
powerplus's Avatar
 
Join Date: Oct 2014
Location: berkshire
My Motorhome: swift sundance 620fb
Posts: 1,243
Thanks: 10
Thanked 126 Times in 120 Posts
hi

i would suggest that you first address the water ingress issue as most smaller engines have a cover on top of the engine to divert the water away

there has been lots of discussions on here in the past about ways to stop the water getting onto the electrics and 1 is to make extra holes in the scuttle and run the water away with added pipework and also to seal the scuttle where it sits on the windscreen

i also remember that there was an issue where the wiring harness chafed under the bonnet

i am surprised yours does not have a cover over the injectors to keep them dry

barry
roy660 likes this.

Last edited by powerplus; 16-12-2019 at 09:21.
powerplus is offline  
post #17 of 21 (permalink) Old 16-12-2019, 17:28 Thread Starter
Junior Member
 
Join Date: Dec 2019
My Motorhome: I drive...
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
i fitted cheap new ones of ebay with wire on them im going to buy fait ones and refit all of them again i did solder all wires together

thanks
eurajohn likes this.
roy660 is offline  
post #18 of 21 (permalink) Old 16-12-2019, 17:33 Thread Starter
Junior Member
 
Join Date: Dec 2019
My Motorhome: I drive...
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
hi thanks for your help i will seal and fix the scuttle tomorrow there is a small engine cover on the engine but there still a lot of water around injectors
roy660 is offline  
post #19 of 21 (permalink) Old 12-03-2020, 17:42
Junior Member
 
Join Date: Mar 2020
My Motorhome: I drive...
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Water? Engine Limp Mode 3.0 Ducato 2012

Hi - I'm having exactly the same issue - keep going into limp mode - replaced injector 1 as per the diagnostics then OK for about 45 minutes then back to red engine light & limp mode ;-( Now saying injector 2 in faulty but just not convinced. Like you 2012 Ducato 3.0 auto with just 15,000 miles on the clock and only recently discovered water sitting in the injector rail through poor design. I think it may be worse than we're only using occasionally as daily users are probably evaporating any water by running the engine hot more often.

Not sure where to go from here - Fiat diagnostics software feels more like 'best guess' I'm feeling! Any engineers out there who could help steer me in the right direction? As per someone else's suggestion, I took the R/H headlight out and checked underneath for potential water ingress/rusting there but it was totally dry and everything seemed perfectly OK. Any help/suggestions would be greatly appreciated.

Last edited by Cirmo; 12-03-2020 at 17:57. Reason: Problem more obvious in title
Cirmo is offline  
post #20 of 21 (permalink) Old 13-03-2020, 08:30
Senior Member
 
KeithChesterfield's Avatar
 
Join Date: Mar 2010
Location: Guess!
My Motorhome: Pilote Reference P716
Posts: 3,245
Thanks: 58
Thanked 143 Times in 97 Posts
Personal Aire
Are there any other lights showing on the dashboard that shouldn't be - that would indicate a possible fault with the ECU which is a well known problem with Ducato of that age.


For Videos of the Aires we've used, Eurotunnel journeys and many other more obscure Videos have a look at - www.youtube.com/user/KeithChesterfield

For Recommended Vets in Europe have a look at - https://www.google.com/maps/d/viewer?msa=0&mid=zTPBDq9Df4L4.kSm3eLuvVb2g
KeithChesterfield is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Motorhome Forums, Motorhome Discussion, Motorhome Chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome