Fiat Ducato 2003 Pre-heat light - Motorhome Forums, Motorhome Discussion, Motorhome Chat

User Tag List

 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 16-01-2015, 17:53 Thread Starter
Senior Member
 
Join Date: May 2009
Location: UK and Katowice, Poland, plus All Europe
My Motorhome: Niesmann+Bischoff Arto 69GL (2003)
Posts: 12,880
Thanks: 900
Thanked 489 Times in 435 Posts
Fiat Ducato 2003 Pre-heat light

For some time now, after normal engine start, the pre-heat light flashes for about 20 seconds. No other problems.

I am sure it did not do this 3-4 years ago.

There is nothing in the manual.

Is there an actual, or impending, fault of any significance?

Geoff
nicholsong is online now  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 16-01-2015, 20:23
Member
 
Ketvrin's Avatar
 
Join Date: Sep 2011
Location: Northumberland
Posts: 95
Thanks: 0
Thanked 0 Times in 0 Posts
I believe this is telling you there is a fault with one or more glow plugs. I would change the lot rather than just the faulty one(s).

Good luck

K
Ketvrin is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Motorhome Forums, Motorhome Discussion, Motorhome Chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome