Injection System Failure Fiat Ducato 07 - Motorhome Forums, Motorhome Discussion, Motorhome Chat

User Tag List

 
LinkBack Thread Tools
post #1 of 8 (permalink) Old 27-03-2009, 07:26 PM Thread Starter
Member
 
Join Date: Feb 2009
Location: Co Durham
Posts: 41
Injection System Failure Fiat Ducato 07

Hi,

Just pulled my Auto Trail Apache out of storage park tonight to bring home and clean up Drove it last week with no problems). 160hp version and goes very well. The Engine management light came on a couple of miles from home and engine went into "limp mode" . I guess i'll need to take it to my local Fiat dealer so they can do the diagnostics. Has anyone had a similar experience and what was the outcome?

Thanks

Richie
dickydutch is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 27-03-2009, 07:46 PM
Senior Member
 
waspes's Avatar
 
Join Date: Feb 2008
Location: Vale Of Glamorgan South Wales.
Posts: 373
Hi, the same thing happened to me last week. I am in Spain and it wouldn't start. When it did I could not rev it and it was bellowing out smoke.
I took it to a Fiat dealer in Salamanca who informed me that I needed a new part that would have taken 4 days to come. It seemed to clear itself so he told me that I could wait until I get back to the UK, if I wanted.
It seems to be ok now and I am not back until June, so fingers crossed that it will be alright until then.

Peter.
waspes is online now  
post #3 of 8 (permalink) Old 27-03-2009, 08:20 PM Thread Starter
Member
 
Join Date: Feb 2009
Location: Co Durham
Posts: 41
Peter,

Thanks for that. Ill definitely get to my Fiat dealer asap as running at a max of 3000rpm is no good at all. Hope the sun is shining where you are, windy but dry in County Durham!


Cheers
dickydutch is offline  
post #4 of 8 (permalink) Old 27-03-2009, 08:39 PM
Senior Member
 
Join Date: Mar 2008
Location: surrey
Posts: 1,153
try this unplug the ecu leave for 60 seconds then plug it in again this might clear it.dennis
brillopad is offline  
post #5 of 8 (permalink) Old 27-03-2009, 08:42 PM
Senior Member
 
Join Date: Sep 2005
Location: Essex
Posts: 3,990
Hi

I have had the engine management light come on twice on my bus. The first time it just needed an injection flash and the second time was the throttle valve which failed and a new part had to be ordered and fitted.

steve
Chigman is offline  
post #6 of 8 (permalink) Old 27-03-2009, 09:01 PM
Senior Member
 
1943's Avatar
 
Join Date: May 2008
Location: Cornwall
Posts: 473
It happened to us last year (2008 bessacarr) took it to Fiat dealer. They ran it up on the computer and couldn't find a fault so they reset it. They said "sometimes they trick themselves, especially if the battery has been very low or flat". Hasn't happened since touch wood.

fingers crossed for you

Bob
1943 is online now  
post #7 of 8 (permalink) Old 27-03-2009, 09:04 PM
Senior Member
 
Join Date: Mar 2008
Location: surrey
Posts: 1,153
do as i said and that will reset it
brillopad is offline  
post #8 of 8 (permalink) Old 27-03-2009, 09:44 PM Thread Starter
Member
 
Join Date: Feb 2009
Location: Co Durham
Posts: 41
Quote:
Originally Posted by brillopad
do as i said and that will reset it

Thanks all!

Dennis, where is the ECU?, is this in the engine bay or under the facia. I only have 2000 miles on this motor so don't expect any major component failure. Saying that FIAT always stood for "Fix It Again Tomorrow"

Cheers,

Richie
dickydutch is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Motorhome Forums, Motorhome Discussion, Motorhome Chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO 3.6.1