Truma water heater problem - Motorhome Forums, Motorhome Discussion, Motorhome Chat
User Tag List

 
LinkBack Thread Tools
post #1 of 7 (permalink) Old 06-06-2011, 10:58 PM Thread Starter
Senior Member
 
sooty10's Avatar
 
Join Date: Feb 2009
Location: Somewhere between Nelson and Benalmadena Costa
Posts: 280
Truma water heater problem

Just been away at the Stratford show and our Truma water heater has stopped working on gas. When the dial is switched on, a click can be heard but no gas ignites. The light goes green but after a few seconds turns to red. It is working ok on Electric hook up. Any ideas?.

Sooty
sooty10 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 06-06-2011, 11:09 PM
Senior Member
 
Jezport's Avatar
 
Join Date: Jun 2008
Location: Leeds, West Yorkshire
Posts: 3,316
Jezport is offline  
post #3 of 7 (permalink) Old 06-06-2011, 11:11 PM
Senior Member
 
rogerblack's Avatar
 
Join Date: May 2005
Location: Berkshire/Fife/France
My Motorhome: Autosleeper Pollensa 2002 on Peugeot Boxer 2.8HDi
Posts: 1,835
Re: Truma water heater problem

Quote:
Originally Posted by sooty10
Just been away at the Stratford show and our Truma water heater has stopped working on gas. When the dial is switched on, a click can be heard but no gas ignites. The light goes green but after a few seconds turns to red. It is working ok on Electric hook up. Any ideas?.

Sooty
I assume you have remembered to remove the exterior cowl cover if fitted? Sorry to state the bleedin' obvious but I have been caught by this myself a couple of times - doh!

cheers
Roger
rogerblack is offline  
post #4 of 7 (permalink) Old 06-06-2011, 11:30 PM Thread Starter
Senior Member
 
sooty10's Avatar
 
Join Date: Feb 2009
Location: Somewhere between Nelson and Benalmadena Costa
Posts: 280
Plenty of gas, fridge and oven working well. Cover removed, one day working well, next day nothing.

Keith
sooty10 is offline  
post #5 of 7 (permalink) Old 06-06-2011, 11:50 PM
Senior Member
 
clive1821's Avatar
 
Join Date: Mar 2010
Location: West Oxford
Posts: 1,823
now we come down to the teck bit then, when you start the gas can you hear the ticking of the egnighter ? goes on for about 15 secs
clive1821 is offline  
post #6 of 7 (permalink) Old 07-06-2011, 12:02 AM Thread Starter
Senior Member
 
sooty10's Avatar
 
Join Date: Feb 2009
Location: Somewhere between Nelson and Benalmadena Costa
Posts: 280
Just a click at the start but no ticking.

Keith
sooty10 is offline  
post #7 of 7 (permalink) Old 07-06-2011, 12:09 AM
Senior Member
 
clive1821's Avatar
 
Join Date: Mar 2010
Location: West Oxford
Posts: 1,823
ok i was going to say just check the gas icolator and turn it around 360 digrees just to check it.... no egnighter a..... just check the wires have not come off the unit its usually located on one of the surport legs.... if you have a red light that indicated you have power to the main PCB... just check the volts are there on the pcb and then take the cover off and just check the fuse.... not much point as the thud is the main gas valve opening and that gets its power from the main pcb then next is to find some one with a good pcb and swap it over and check that... it goes on a bit....
clive1821 is offline  
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Motorhome Forums, Motorhome Discussion, Motorhome Chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO 3.6.1